欢迎

欢迎使用 Registry Workshop

Registry Workshop 是一个高级注册表编辑器。它可以被用来作为 Windows 自带注册表编辑器 RegEdit 和 RegEdt32 替代品。

除了注册表编辑器应有的基本功能外，Registry Workshop 提供了很多功能来提高管理注册表的效率。例如，剪切、复制和粘贴注册表项和值，撤销和重做编辑操作，快速搜索替换注册表内容，方便的收藏夹管理，等等。

无论您是一个需要编辑注册表来删除木马、病毒注册表项的计算机高级用户，还是一个需要安全高效的注册表工具管理公司计算机的系统管理员，或者是一个需要在开发中快速操作注册表的软件开发人员，Registry Workshop 都能满足您的需求。


主要功能

  • 多重撤销和重做。

  • 高速搜索和替换。

  • 在计算机及文件之间比较注册表。

  • 通过 ActiveSync 编辑移动设备的注册表。

  • 剪切、复制和粘贴注册表项和值。

  • 支持鼠标拖放。

  • 以编辑系统注册表的方式来编辑注册表文件。

  • 备份和还原注册表。

  • 整理注册表。

  • 提供便于管理的收藏夹。

  • 提供地址栏、书签和访问记录来提高浏览注册表的效率。

  • 自动分析注册表项和值中的数据，如果其中包含ProgID、ClassID、文件路径或网页地址，可以通过上下文菜单进行相应的跳转。

  • 快速在 HKLM 和 HKCU 中相同名字的注册表项间跳转。

  • 快速在 Wow6432Node 和非 Wow6432Node 中相同名字的注册表项间跳转。

  • 允许打开多个本机注册表窗口。

  • 如果用户有管理员权限，可以在不修改注册表权限的情况下打开没有访问权限的注册表项。


安装

系统需求

  • Windows XP
  • Windows Vista
  • Windows 7
  • Windows 8
  • Windows 10

安装

执行下载的安装程序。

卸载

执行开始菜单 Registry Workshop 中的 'Uninstall'，或者在控制面板 '添加/删除程序' 中双击 'Registry Workshop'。


许可协议

最终用户许可协议

请务必仔细阅读和理解本用户许可协议中的内容，并决定接受或不接受本协议的条款。除非接受了本协议的条款，否则请不要安装本软件在您的计算机上；您一旦安装了本软件，即自动表示您已同意接受本协议以下各项条款。

试用和注册

本软件为共享软件。您可以以试用为目的免费使用本软件30天，如果超出30天试用期，必须注册才能使用。

试用版本

您可以任意复制分发本软件的试用版本，但是不能收取任何费用。

注册版本

一份注册的本软件可以被一个人在多台计算机上使用，或者安装在一台计算机上被多人使用。您可以从网络上访问注册的本软件，但是必须为运行本软件的每台计算机购买许可证。

对逆向工程的限制

您不得对本软件进行修改、逆向工程、反编译或反汇编。

无担保

Torchsoft明示不为本软件做任何担保。使用本软件所引起的全部风险由您自己承担。


软件注册

Registry Workshop 不是免费软件，您可以以试用为目的免费使用本软件30天，如果超出30天试用期，必须注册才能使用。

注册用户的权力

  • 免费升级。

  • 通过电子邮件获得免费的技术支持。


Support

软件网址

请访问以下网址获取关于 Registry Workshop 的最新信息，您也可以在以下网址下载到最新的版本。
http://www.torchsoft.com

用户反馈

请将Bug、建议、问题以及评论发送到以下地址。
support@torchsoft.com

如果您要报告一个Bug，请提供以下信息：

  • Bug是否可以重现？如果可以重现，请描述详细的步骤。

  • 本软件的版本。

  • Windows 版本。

  • 如果有出错信息，请提供准确的出错信息文字。


常见问题

  • 各注册表配置单元的对应文件是什么?
  • 如何修改已经不能启动的Windows系统中的注册表?
  • 有一个注册表项删除不了，我该怎么办?
  • 可以在地址栏中使用注册表根项缩写吗?
  • 注册表快照中只有 HKLM 和 HKU 的内容，HKCR, HKCU 和 HKCC那里去了?

各注册表配置单元的对应文件是什么?

Windows 在注册表中 HKLM\SYSTEM\CurrentControlSet\Control\hivelist 下维护了一个配置单元及其存放文件的列表。下面的表中显示了标准的配置单元与其对应的文件。

注册表配置单元 | 文件
HKLM\SAM | %SystemRoot%\System32\Config\SAM
HKLM\SECURITY | %SystemRoot%\System32\Config\Security
HKLM\SOFTWARE | %SystemRoot%\System32\Config\Software
HKLM\SYSTEM | %SystemRoot%\System32\Config\System
HKU\.DEFAULT | %SystemRoot%\System32\Config\DEFAULT
HKU\SID | Documents and Settings\userName\NTUSER.DAT
HKU\SID_Classes | Documents and Settings\userName\Local Settings \Application Data\Microsoft\Windows\UsrClass.dat

如何修改已经不能启动的Windows系统中的注册表?

您可以将安装该系统的硬盘安装到其他计算机，使用加载配置单元功能加载需要修改的配置单元，修改后再卸载配置单元。

有一个注册表项删除不了，我该怎么办?

如果您确认不是权限不足的问题，可以尝试以下的方法：

  • 选择一个注册表项，将其导出为配置单元文件，考虑性能的因素，请不要选择一个包含很多内容的注册表项。
  • 选择要删除项的上一级注册表项，如果上一级注册表项中还有其他的注册表条目，请项这些注册表条目导出。
  • 导入配置单元文件，这将覆盖上一级注册表项中的所有内容。
  • 删除导入的内容并恢复以前的内容。

可以在地址栏中使用注册表根项缩写吗?

是的，您可以使用以下缩写。

注册表根项 | 缩写
HKEY_CLASSES_ROOT | HKCR
HKEY_CURRENT_USER | HKCU
HKEY_LOCAL_MACHINE | HKLM
HKEY_USERS | HKU
HKEY_CURRENT_CONFIG | HKCC

注册表快照中只有 HKLM 和 HKU 的内容，HKCR, HKCU 和 HKCC那里去了?

HKLM 和 HKU 包含了所有的注册表数据，HKCR, HKCU 和 HKCC 仅仅是符号链接。

注册表根项 | 链接
HKCR | HKCU\Software\Classes + HKLM\SOFTWARE\Classes
HKCU | HKU\SID
HKCC | HKLM\SYSTEM\CurrentControlSet\Hardware Profiles\Current


快捷键

下表列出了 Registry Workshop 中的快捷键。

快捷键 | 说明
F1 | 打开帮助文件
Ctrl + N | 建立新注册表文档
Ctrl + O | 打开一个现有文档
Ctrl + S | 保存活动文档
Alt + F4 | 退出 Registry Workshop
Alt + Enter | 打开注册表项属性对话框
Ctrl + A | 选中列表中的全部项目
Ctrl + Z | 撤销最后一步操作
Ctrl + Y | 重新执行先前已撤销的操作
Ctrl + C, Ctrl + Ins | 复制被选内容并将其置于剪贴板上
Ctrl + X, Shift + Del | 剪切被选内容并将其置于剪贴板上
Ctrl + V, Shift + Ins | 插入剪贴板内容
Del | 删除被选内容
F2 | 重命名被选内容
Ctrl + F | 打开查找对话框
Alt + F3 | 使用上一次的查找标准重新搜索
F3 | 跳转到上次查找结果中下一个匹配的项或值
Shift + F3 | 跳转到上次查找结果中上一个匹配的项或值
Ctrl + G | 打开跳转到注册表项对话框
Alt + D | 激活地址栏
F4 | 激活地址栏并显示地址历史列表
F5 | 刷新显示
F6 | 跳转到下一个书签
Shift + F6 | 跳转到上一个书签
Ctrl + [1, 2, 3, 4, 5, 6, 7, 8, 9, 0] | 设置或清除书签
Alt + [1, 2, 3, 4, 5, 6, 7, 8, 9, 0] | 跳转到指定书签
F7 | 在注册表窗口和当前浮动面板窗口之间切换
Ctrl + F7 | 切换到下一个浮动面板窗口
Ctrl + Shift + F7 | 切换到上一个浮动面板窗口
Tab | 在注册表窗口的树窗口和列表窗口之间切换，或者在比较结果窗口中的两个列表间切换
Ctrl + Tab | 切换到下一个注册表窗口
Ctrl + Shift + Tab | 切换到上一个注册表窗口
F11 | 在比较结果列表中移动焦点到下一条
Shift + F11 | 在比较结果列表中移动焦点到上一条
Backspace | 显示上一层注册表内容
Alt + Up Arrow | 显示上一层注册表内容
Ctrl + Back Mouse Button | 显示上一层注册表内容
Alt + Left Arrow | 跳转到注册表访问历史中的前一项
Back Mouse Button | 跳转到注册表访问历史中的前一项
Alt + Right Arrow | 跳转到注册表访问历史中的下一项
Forward Mouse Button | 跳转到注册表访问历史中的下一项
Applications key, Shift + F10 | 显示上下文菜单
Middle Mouse Button | 通过在标签中点击鼠标中键来关闭一个注册表窗口
Shift + ~ | 在 Wow6432Node 和非 Wow6432Node 中相同名字的注册表项间跳转
Ctrl + ~ | 在 HKLM 和 HKCU 中相同名字的注册表项间跳转
Ctrl + E | 将选定的注册表项和值导出为一个文件
Ctrl + Q | 将一个配置单元文件加载到注册表
Ctrl + W | 从注册表卸载一个配置单元
Ctrl + T | 切换总在最前面状态
Ctrl + R | 在查找结果1中替换


命令行语法

Registry Workshop 提供了几种命令行用法以方便用于批处理文件中或用于命令窗口中。

RegWorkshop.exe [选项] [文件名] [注册表路径]
[文件名] | 在 Registry Workshop 中打开注册表文件。
/g [注册表路径] | 打开 Registry Workshop 并跳转到 [注册表路径].
/f [字符串] | 打开 Registry Workshop 并使用默认参数在整个注册表中搜索 [字符串].
/s [文件名] | 导入注册表文件，不显示确认提示。
/e [文件名] [注册表路径] | 导出 [注册表路径] 到 [文件名]。 示例: RegWorkshop /e c:\temp.reg "HKEY_CURRENT_USER\Control Panel"
/a [文件名] [注册表路径] | 与 /e 相同，只是生成 Win9x/NT 注册表文件。
/n [计算机名字或地址] | 连接网络注册表

注意事项

  • 如果 [文件名] 和 [注册表路径] 中包含空格，必须用双引号括起来。

  • 使用 /s, /e 和 /a 选项时，Registry Workshop 将不显示界面。

reg:协议语法

Registry Workshop 支持reg:协议，您可以使用浏览器的地址栏中输入指令打开Registry Workshop并跳转到指定的注册表项，此功能也可以被用来在网页和文档中创建注册表项的连接，通过点击连接即可打开Registry Workshop并跳转到相应的注册表项。

reg:[注册表路径]

示例1: reg:HKEY_CURRENT_USER\Control Panel
示例2: reg:HKCU\Control Panel

注意事项

  • 不要用双引号将[注册表路径]括起来。


新建注册表项

添加一个注册表项

  1. 在注册表项树中，选中要在其下添加新项的注册表项。
  2. 打开 编辑 菜单，点击 新建项。
  3. 输入新注册表项的名字，然后按回车。


新建注册表值

添加一个注册表值

  1. 选中要在其下添加新值的注册表项。

  2. 打开 编辑 菜单，将鼠标指向 新建值，然后点击要添加的值的类型：字符串值，二进制值，整数值，多行字符串值，可扩展字符串值，倒序整数值，QWORD值，Link值，Resource List值，Full Resource Descriptor值，Resource Requirements List值。

  3. 输入新注册表值的名字，然后按回车。


修改值

修改一个注册表值

  1. 选中要修改的注册表值。
  2. 打开 编辑 菜单，点击 修改。
  3. 在 数值数据 中，输入新的数据，然后点击 确定。


删除项和值

删除注册表项和值

  1. 选中要删除的注册表项和值。
  2. 打开 编辑 菜单，点击 删除。


重命名项和值

重命名一个注册表项或值

  1. 选中要重命名的注册表项或值。
  2. 打开 编辑 菜单，点击 重命名。
  3. 输入新名字，然后按回车。


剪切

剪切注册表项和值

  1. 选中要剪切的注册表项和值。
  2. 打开 编辑 菜单，点击 剪切。


复制

复制注册表项和值

  1. 选中要复制的注册表项和值。
  2. 打开 编辑 菜单，点击 复制。


粘贴

粘贴注册表项和值

  1. 选中要粘贴到的注册表项。
  2. 打开 编辑 菜单，点击 粘贴。


权限

修改一个注册表项的权限

  1. 选中要修改权限的注册表项。
  2. 打开 编辑 菜单，点击 权限。


复制项名称

复制一个注册表项的名称

  1. 选中要复制项名称的注册表项。
  2. 点击鼠标右键显示弹出菜单。
  3. 如果要复制完整的项路径，点击 复制完整项名称。如果只需要复制项名字，点击 复制项名称。
  4. 粘贴项名称到其它软件或文档。


复制值名称

复制一个注册表值的名称

  1. 选中要复制名称的注册表值。
  2. 点击鼠标右键显示弹出菜单。
  3. 点击 复制值名称。
  4. 粘贴注册表值名称到其它软件或文档。


复制值数据

复制一个注册表值的数据

  1. 选中要复制数据的注册表值。
  2. 点击鼠标右键显示弹出菜单。
  3. 点击 复制值数据。
  4. 粘贴注册表值数据到其它软件或文档。


标记为删除

将注册表项和值标记为删除

本功能仅用于注册表文件，通过本功能您可以在注册表文件中加入删除指令。

  1. 选中要标记为删除的注册表项和值。
  2. 点击鼠标右键显示弹出菜单。
  3. 点击 标记为删除。

注意事项

  • 如果注册表项已经被标记为删除，执行此操作将去掉删除标记。
  • 如果您需要达成导入注册表文件时删除指定注册表项的目的，必须删除文件中标记为删除的项的所有子项和值。
  • 本操作不能撤销。


查找

在注册表中查找

  1. 如果您打算查找指定的注册表项，先选中该项。
  2. 打开 搜索 菜单，点击 查找。
  3. 在 查找内容 中，输入要查找的内容。

  4. 根据需要，选择 搜索项，搜索值，搜索数据，以及 区分大小写，匹配整个字符串，使用通配符搜索，使用二进制搜索 等选项。

  5. 根据需要，选择 搜索整个注册表 或 在此项中搜索。
  6. 点击 查找。
  7. 查找状态窗口将出现，您可以点击 取消 按钮来停止搜索。

如何使用通配符搜索?

您可以使用 '*' 和 '?' 作为通配符，'*' 表示零个或多个字符，'?' 表示任意单个字符。例如，要想查找所有以 "abc" 开头的内容, 输入 "abc*" 来搜索。

注意

  • 重复的结果将被自动从查找结果中删除。
  • 二进制搜索应当只被用来搜索非文本内容。
  • 您可以查找部分注册表路径。例如，搜索 "Microsoft\Command" 时 "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Command Processor" 将会被找到。但是这些查找结果不能被替换。


替换

在查找结果中替换

  1. 切换到查找结果窗口，如果要部分替换查找结果，先选择要替换的查找结果。
  2. 打开 搜索 菜单，点击 在查找结果x中替换。
  3. 在 替换为 中，输入要替换成的内容。

  4. 根据需要，选择 搜索项，搜索值，搜索数据，以及 区分大小写，匹配整个字符串 等选项。

  5. 根据需要，选择 搜索整个查找结果 或 搜索选定的项目。
  6. 点击 替换。

注意

  • 使用通配符搜索或二进制搜索时，替换功能将被禁止。
  • 成功替换的项目将被从查找结果窗口中移除。


备份和还原

备份和还原本地注册表

打开 文件 菜单，点击 备份和还原 打开备份和还原对话框。

备份注册表

  1. 点击 备份。
  2. 在 说明 中输入此备份的说明。
  3. 在 注册表配置单元 中选择要备份的配置单元。
  4. 点击 确定。

还原注册表

  1. 选中要还原的注册表备份。
  2. 点击 还原。
  3. 点击 是。

编辑备份说明

  1. 选中要编辑说明的注册表备份。
  2. 点击 编辑。
  3. 在 说明 中输入新的说明。
  4. 点击 确定。

删除备份

  1. 选中要删除的注册表备份。
  2. 点击 删除。
  3. 点击 是。


备份到

备份本地注册表到指定文件夹

  1. 打开 文件 菜单，点击 备份到。

  2. 在 浏览文件夹 对话框中，选择要用来存放备份的文件夹并点击 确定。
  3. 在 说明 中输入此备份的说明。
  4. 在 注册表配置单元 中选择要备份的配置单元。
  5. 点击 确定。


还原自

从指定的文件夹还原本地注册表

  1. 打开 文件 菜单，点击 还原自。
  2. 在 浏览文件夹 对话框中，选择存放备份的文件夹并点击 确定。
  3. 点击 确定。


整理注册表

整理本地注册表

  1. 打开 文件 菜单，点击 整理注册表。
  2. 点击 确定。
  3. 在 整理注册表 对话框中，选择要整理的注册表配置单元。
  4. 点击 确定。

整理注册表是如何工作的?

整理注册表是通过重新创建每一个注册表配置单元来实现的，相当于一次完整的备份还原。如果你刚进行了注册表还原，就不需要做注册表整理。


导入注册表文件

导入部分或全部注册表

  1. 打开 文件 菜单，点击 导入。
  2. 在 文件类型 中，选择注册表文件。
  3. 找到要导入的文件, 点击 打开。


导出注册表文件

将全部或部分注册表导出到文本文件中

  1. 选择要导出的注册表项 和/或 值。
  2. 打开 文件 菜单，点击 导出。
  3. 在 文件名 中，输入文件名。
  4. 在 保存类型 中，选择 Win2K/XP 注册表文件 或 Win9x/NT 注册表文件。
  5. 点击 保存。


导入配置单元

从配置单元文件中导入一个注册表项

  1. 选中要从配置单元文件恢复的注册表项。
  2. 打开 文件 菜单，点击 导入。
  3. 在 查找范围 中，选择配置单元文件所在的文件夹。
  4. 在 文件类型 中，选择 配置单元文件。
  5. 选择要导入的文件。
  6. 点击 打开。

注意

如果您选择了根项，配置单元文件 将不会显示在 文件类型 列表中。


导出配置单元

将一个注册表项导出到配置单元文件中

  1. 选择要导出的注册表项。
  2. 打开 文件 菜单，点击 导出。
  3. 在 保存在 中，选择要保存文件的文件夹。
  4. 在 文件名 中，输入文件名。
  5. 在 保存类型 中，选择 配置单元文件。
  6. 点击 保存。


加载配置单元

将一个配置单元文件加载到注册表

  1. 打开 文件 菜单，点击 加载配置单元。
  2. 在 查找范围 中，选择配置单元文件所在的文件夹。
  3. 点击 打开。
  4. 在 项名称 中，输入要指定给配置单元的显示名称。
  5. 在 加载位置 中，选择 HKEY_LOCAL_MACHINE 或 HKEY_USERS。
  6. 点击 确定。


卸载配置单元

从注册表卸载一个配置单元

  1. 选定一个先前被加载的配置单元。
  2. 打开 文件 菜单，点击 卸载配置单元。


注册表快照

创建本地注册表的快照

  1. 打开 文件 菜单，点击 创建本地注册表快照。
  2. 等待几秒钟，一个包含快照内容的注册表窗口将被打开。

注意

您会发现注册表快照中没有 HKCR，HKCU 和 HKCC，因为 HKLM 和 HKU 包含所有的注册表内容，HKCR，HKCU 和 HKCC 只是链接。

    HKCR = HKCU\Software\Classes + HKLM\SOFTWARE\Classes
HKCU = HKU\SID
HKCC = HKLM\SYSTEM\CurrentControlSet\Hardware
Profiles\Current


连接网络注册表

  1. 打开 文件 菜单，点击 连接网络注册表。

  2. 在 连接网络注册表 对话框中，浏览或输入要连接的计算机名字或地址.

注意

在连接之前，您必须在本机和远程计算机上都以系统管理员权限登陆，网络策略设置也可能会阻止您连接到网络注册表。


断开网络注册表

关闭网络注册表窗口即可断开网络注册表。


连接移动设备注册表

  1. 首先与您的移动设备建立 ActiveSync 连接。
  2. 打开 文件 菜单，点击 连接移动设备注册表。

注意

如果您在连移动设备注册表后，断开又重新建立 ActiveSync 连接，您需要按F5刷新注册表窗口。


断开移动设备注册表

关闭移动设备注册表窗口即可断开移动设备注册表。


新建收藏项

添加一个注册表项或值到收藏夹

  1. 选中要添加到 收藏夹 的注册表项或值。
  2. 打开 收藏夹 菜单，点击 添加到收藏夹。
  3. 在 选择类别 对话框中，选择要将收藏项存放到其中的收藏类别，然后点击 确定。
  4. 在 编辑收藏项 对话框中，修改 显示名称，项名称，数值名称 和 说明，然后点击 确定。


新建类别

添加一个类别到收藏夹

  1. 在 收藏夹 窗口中，选中要在其下添加新类别的类别。
  2. 打开 收藏夹 菜单，点击 新建类别。
  3. 输入新类别的名字，然后按回车。


修改收藏项

修改一个收藏项

  1. 在 收藏夹 窗口中，选中要修改的收藏项。
  2. 打开 收藏夹 菜单，点击 修改。

  3. 在 编辑收藏项 对话框中，修改 显示名称，项名称，数值名称 和 说明，然后点击 确定。


删除收藏项或类别

  1. 在 收藏夹 窗口中，选中要删除的收藏项或类别。
  2. 打开 收藏夹 菜单，点击 删除。


重命名收藏项或类别

  1. 在 收藏夹 窗口中，选中要重命名的收藏项或类别。
  2. 打开 收藏夹 菜单，点击 重命名。
  3. 输入新名字，然后按回车。


移动收藏项或类别

移动一个收藏项或类别

  1. 在 收藏夹 窗口中，选中要移动的收藏项或类别。
  2. 打开 收藏夹 菜单，点击 移动到。

  3. 在 选择类别 对话框中，选择要移动到其中的收藏类别，然后点击 确定。

注意

您可以使用拖放操作来移动收藏项或类别。


复制收藏项或类别

复制一个收藏项或类别

  1. 在 收藏夹 窗口中，选中要复制的收藏项或类别。
  2. 打开 收藏夹 菜单，点击 复制到。

  3. 在 选择类别 对话框中，选择要复制到其中的收藏类别，然后点击 确定。

注意

您可以通过拖放的同时按住CTRL键来复制收藏项或类别。


收藏项跳转

跳转到收藏项中存储的注册表项或值

  1. 在 收藏夹 窗口中，双击收藏项。


导入收藏夹

  1. 打开 收藏夹 菜单，点击 导入。
  2. 在 查找范围 中，选择收藏夹文件所在的文件夹。
  3. 选择要导入的文件。
  4. 点击 打开。

注意

如果导入的某个收藏项已经存在，当前的收藏项内容将被覆盖。


导出全部收藏夹

将整个收藏夹导出到文件

  1. 打开 收藏夹 菜单，点击 导出全部。
  2. 在 保存在 中，选择要保存文件的文件夹。
  3. 在 文件名 中，输入文件名。
  4. 在 保存类型 中，选择 Registry Workshop 收藏夹文件 或 RegEdit 收藏。
  5. 点击 保存。


导出选定收藏夹

将选定的收藏类别导出到文件

  1. 在 收藏夹 窗口中，选中要导出的收藏类别。
  2. 打开 收藏夹 菜单，点击 导出选定部分。
  3. 在 保存在 中，选择要保存文件的文件夹。
  4. 在 文件名 中，输入文件名。
  5. 在 保存类型 中，选择 Registry Workshop 收藏夹文件 或 RegEdit 收藏。
  6. 点击 保存。


比较注册表

  1. 打开要比较的网络注册表或注册表文件，如果要比较本地注册表中的两个注册表项，跳过此步骤。
  2. 打开 工具 菜单，点击 比较注册表。
  3. 在 比较注册表 对话框中，选择要比较的注册表以及注册表项。如果要比较所有的项, 请使 注册表项 为空或者 "\"。
  4. 点击 比较。


常规设置

启动时跳转到上次使用的注册表项

选择此项将在启动时自动跳转到上次使用的注册表项。

默认为只读模式

选择此项将设置新打开的注册表窗口为只读模式。您可以通过 编辑 菜单中的 只读模式 菜单项来设置当前注册表窗口是否为只读模式。

允许使用鼠标拖放操作

选择此项将允许使用鼠标拖放执行移动和复制操作。

  • 如果在同一注册表窗口内拖放，将移动注册表项或值。
  • 如果在拖动的同时按住 CTRL 键，将复制注册表项或值。
  • 如果在不同注册表窗口间拖放，将复制注册表项或值。
  • 如果拖动注册表项或值到收藏夹窗口，将添加注册表项或值到收藏夹。
  • 如果在收藏夹窗口内拖放，将在收藏类别间移动或复制收藏夹内容。

尝试强制打开拒绝访问的注册表项

选择此项，如果用户有管理员权限，可以在不修改注册表权限的情况下打开没有访问权限的注册表项。

显示最近使用文件列表

选择此项将在 文件 菜单中显示最近使用文件列表。

最大数目

此设置允许您设置显示在文件菜单中的最近使用文件的最大数目。默认为 10。

在子菜单中显示最近使用文件列表

选择此项，最近使用文件列表将显示在 文件 菜单的子菜单中。如果不选择此项，最近使用文件列表将显示在 文件 菜单本身中。

退出时保存本地注册表的撤销和重做历史数据

选择此项将在软件退出时保存本地注册表的撤销和重做历史数据。

撤销和重做的最大次数

此设置允许您设置撤销和重做的最大次数，如果撤销和重做历史数据超过此设置，最旧的数据将被删除。默认为 1000。

查找结果的最大数目

此设置允许您设置查找结果的最大数目。默认为 1000。

界面语言

此设置允许您选择软件的界面语言。


提示设置

确认删除项和值

选择此项将在执行删除和剪切时弹出确认消息框。

确认覆盖项和值

选择此项将在覆盖已经存在的注册表项和值时弹出确认消息框。

确认使用鼠标拖放时造成的移动操作

选择此项将在使用鼠标拖放来移动注册表项和值，以及收藏项和类别时弹出确认消息框。

确认使用鼠标拖放时造成的复制操作

选择此项将在使用鼠标拖放来复制注册表项和值，以及收藏项和类别时弹出确认消息框。

确认导入配置单元文件

选择此项将在导入注册表配置单元文件时弹出确认消息框。

确认在历史窗口中执行撤销或重做

选择此项将在历史窗口中执行“撤销此操作”、“重做此操作”或“执行到此处”时弹出确认消息框。

当跳转到不存在的项时，提示创建项

选择此项将在跳转到不存在的注册表项时提示用户是否创建丢失的项。

当跳转到不存在的值时，显示错误信息

选择此项将在跳转到不存在的注册表值时提示错误。

在查找完成后播放声音

选择此项将在查找执行完成后播放声音。

当导出注册表到文件时，提示输入文件注释

选择此项将在导出注册表到文件时，打开编辑注释对话框。如果不想输入注释，直接确定即可。


显示设置

在列表窗口中显示注册表项

选择此项将在列表窗口中显示注册表项和值。

在列表窗口中使用整行选择方式

选择此项将在列表窗口中使用整行选择方式。

拒绝访问的注册表项的显示颜色

此设置允许您修改没有存取权限的注册表项的显示颜色。

注册表文件中标记为删除的项目的显示颜色

此设置允许您修改正在编辑的注册表文件中，被标记为删除的注册表项和值的显示颜色。

查找结果中的匹配部分的显示颜色

此设置允许您修改查找结果中匹配部分的显示颜色。

书签的显示颜色

此设置允许您修改设置为书签的注册表项和值的背景颜色。

字体

此设置允许您修改各树控件和列表控件中的字体。


文件位置设置

收藏夹

指定收藏夹文件的存放位置，Registry Workshop 在启动时将尝试从此位置装载收藏夹文件 favorites.dat 。

注册表备份

指定注册表备份文件的存放位置。

HTML 报表

指定 HTML 报表的存放位置。


外壳集成设置

在 .reg 文件的右键菜单上显示相关菜单项

选择本项将在右键点击 .reg 文件时，在右键菜单上显示 'Registry Workshop' 菜单项，执行此菜单项将打开 Registry Workshop 来编辑该文件。

在系统桌面上显示本软件快捷方式

选择本项将在系统桌面创建本软件的快捷方式，清除本项将从桌面删除本软件的快捷方式。